Back to overview

User interfaces are down

May 19, 2026 at 9:12pm UTC
Affected services
myvet.mypethq.io
app.mypethq.io

Resolved
May 19, 2026 at 10:29pm UTC

Netlify have notifed us that the issue is solved and they're monitoring.

Created
May 19, 2026 at 9:12pm UTC

Both MyVet and app are experiencing issues as our service provider Netlify is down. We'll update this as we know more and decide a path forward.

This incident now looks resolved.